Files
renovate/lib/modules/versioning/elm
renovate[bot] 196101a6bb chore(deps): update dependency oxlint-tsgolint to v0.25.0 (main) (#44424)
* chore(deps): update dependency oxlint-tsgolint to v0.25.0

| datasource | package         | from   | to     |
| ---------- | --------------- | ------ | ------ |
| npm        | oxlint-tsgolint | 0.23.0 | 0.25.0 |

* chore: fix new no-unnecessary-type-assertion findings

Co-Authored-By: Claude Fable 5 <noreply@anthropic.com>

---------

Co-authored-by: renovate[bot] <29139614+renovate[bot]@users.noreply.github.com>
Co-authored-by: Sebastian Poxhofer <sebastian.poxhofer@stedi.com>
Co-authored-by: Claude Fable 5 <noreply@anthropic.com>
2026-07-28 07:04:21 +00:00
..
…

Elm enforces strict Semantic Versioning at the compiler level, automatically detecting API changes and requiring appropriate version bumps.

Ranges

Elm packages use range constraints in the format 1.0.0 <= v < 2.0.0, where the lower bound is inclusive and the upper bound is exclusive.

Exact versions

Elm applications use exact versions like 1.0.0 in their elm.json files.

Both exact versions and ranges are fully supported.